Jump to content

Custom Search





Welcome to the Ford Flex Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Flex Forum. Like most online communities, you must register to create topics or post in our community - but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the Ford Flex Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Dealerships can't solve my problem... Need advice, please.


  • Please log in to reply
No replies to this topic

#1 OFFLINE   hawkeye8s

hawkeye8s

    New Flex Member

  • Ford Flex Members
  • 2 posts
  • Region:U.S. Southern Atlantic
  • Location:Huntsville, AL
  • Current Vehicle:2014 Ford Flex SEL

Posted 02 May 2017 - 07:53 AM

I have a 2014 Ford Flex SEL (AWD).  We bought it used (one year old) from a Lincoln dealership in Huntsville, AL.  Shortly after, I noticed a "creak" in coming from the left wheel well when I turned right.  I brought it to the Lincoln dealer, who had it for 4 days trying to figure it out.  They ordered a sway bar link, and called it "fixed".  I had to pay my $100 Lincoln Premium Care extended warranty fee.  After a day or two, I noticed that although it was better, it still "creaked".  During this time we had our first child.  I started a new job.  Basically I was busy and sort of forgot about it (it's the wife's car).  A year later, the "creak" is really bad.  And now there is a loud "click" when driving.  This time I figured I would bring it to the local Ford dealership, hoping that they would know what's wrong and fix it right.  Well, we're on day 7 and I still don't have my car back.  In fact, they asked me to come down and take a ride with the technician the very first day.  He already replaced a broken sway bar link, but there's still a really loud "click" from the drivers side wheel well, and the creak is still there when turning right. 

 

Any ideas or thoughts?  We're about to have our second child.  I'm hesitant to put my wife and children into a vehicle that's having "mystery" issues.  I really like the Flex.  My wife loves the Flex.  So I'm hoping to not have to trade it in.  I've got to be honest...  If I do, I'll never buy a Ford again.  And that makes me upset.  My grandparents drove Lincolns.  My parents drive Fords.  Hell, my first car was a '71 Ford Torino GT.  I hate to say it, but I've never had these types of issues with my foreign cars.  Well, I say foreign, but my Subaru was made in Indiana.  Any help is appreciated.  Thanks in advance.

 

V/R,

 

Brandon








Custom Search




Privacy Policy Terms of Service ·