Jump to content

Custom Search





Welcome to the Ford Flex Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Flex Forum. Like most online communities, you must register to create topics or post in our community - but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the Ford Flex Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos. . .more!
Click here to create an account
 
Guest Message by DevFuse

Feel Faster?  We're Now on a Dedicated Server!


Photo
- - - - -

2011 Ford Flex Temp light illuminated but gauge at cold


  • Please log in to reply
No replies to this topic

#1 OFFLINE   Texas11 Ford Flex

Texas11 Ford Flex

    New Flex Member

  • Ford Flex Members
  • 1 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Current Vehicle:2011 Ford Flex SEL

Posted 09 February 2017 - 06:59 PM

I own a 2011 Flex SEAL with 85k. The last real cold snap we had, in the 20's my wife was driving the car. Shortly after she started driving and the temp warning light came on but the gauge was on cold. Car dies and restarted and ran fine. Has not happened again but I have noticed sometime on acceleration the engine sounds like a diesel but stops once pedal gas is released noise stops. Almost always seems to happen when tank is 1/4 full. Don't know if these issues are related.

Thanks for you input.






Custom Search




Privacy Policy Terms of Service ·