Jump to content

Custom Search





Welcome to the Ford Flex Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Flex Forum. Like most online communities, you must register to create topics or post in our community - but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the Ford Flex Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos. . .more!
Click here to create an account
 
Guest Message by DevFuse

Feel Faster?  We're Now on a Dedicated Server!


Photo
- - - - -

Right side temp control not working (dual zone)

climate control a/c

  • Please log in to reply
7 replies to this topic

#1 OFFLINE   mbiskup

mbiskup

    New Flex Member

  • Ford Flex Members
  • 2 posts
  • Location:Atlanta, GA
  • Current Vehicle:2010 Flex

Posted 07 October 2012 - 10:51 AM

2010 Flex SEL w/ dual zone A/C and digital control/navigation system.

Problem:
Passenger side (front zone) temperature control not functioning (not responding to A/C touch screen nor physical buttons).

Left side responds fine to temperature control inputs.

Checked fuses #43 and #45 in interior fuse box, they're fine.

Looking around the web I've noticed that there are Ford sites with schematics. So far I haven't found service manual type instructions of where to find the temperature control gate, how to test whether the part is working or some other troubleshooting procedure other than buying parts at the auto store and replacing them until I find the correct part.

Fairly adept at auto mechanics so I think I can chase this down if I have the right diagrams or service-person type troubleshooting conversations on the web.

Any ideas?

Thanks in advance for your input.

Matt

#2 OFFLINE   barburk58

barburk58

    New Flex Member

  • Ford Flex Members
  • 3 posts
  • Region:U.S. Northeast
  • Location:United States
  • Current Vehicle:Flex SEL AWD

Posted 17 December 2013 - 10:32 AM

Matt,

 

I see you did not get any response to this situation.  I am also having this problem with my 2011.  Or at least I a assuming its the same.  Passenger side will only blow cold (well, maybe "ambient" temp) air and will not respond to either general temp control or the Dual Passenger controls.

 

The fan speed blows at the correct settings, but nothing but cold air blows out of the Dash, Defroster of Floor vents.  Driver's side is working properly.

 

Did you ever figure out a fix?

 

BB



#3 OFFLINE   dman928

dman928

    New Flex Member

  • Ford Flex Members
  • 3 posts
  • Region:U.S. Northeast
  • Location:United States
  • Current Vehicle:2009 Ford Flex Limited

Posted 02 January 2014 - 09:28 AM

Sounds like the blend door is broken.  I have the same issue, but have not had the time to locate the blend door that's broken.  There are a couple of them in the dash; one is easy to reach, right behind the glovebox.  The other is near the center of the dash, I believe.



#4 OFFLINE   Tennessee Flexin'

Tennessee Flexin'

    Flexappeal

  • Ford Flex Members
  • 32 posts
  • Region:Decline
  • Location:TN
  • Current Vehicle:2009 LTD and 2017 SEL

Posted 28 June 2015 - 06:15 PM

Same problem here.  Just discovered it tonight.  checking fuses now....

 

fuses good...  I did solve the passenger seat not moving, son kicked wire harness off from second row.  Reconnected, works now.

 

Something major I fear.  Passenger side only blows cold air regardless of a/c on or off and vent setting.  Floor vent on 90, cold air only passenger side.  you get the picture.  


Edited by Tennessee Flexin', 28 June 2015 - 06:48 PM.


#5 OFFLINE   tom54mueller

tom54mueller

    New Flex Member

  • Ford Flex Members
  • 1 posts
  • Region:U.S. Northeast
  • Location:Pennsylvania
  • Current Vehicle:2009 Ford Flex

Posted 03 January 2016 - 09:59 PM

Hi,

Did any of you figure out the problem? I'm having the same issue. Driver side is blowing hot air but passenger side is blowing cold

 

I changed out the one behind the glove box (that would have been too easy of a fix!) but that didn't fix it. I'm reading there are 2 others behind the dash to replace.

 

Does anyone know where the other 2 are located so I can change those out as well?
 

Thanks for the help.



#6 OFFLINE   mattyp

mattyp

    New Flex Member

  • Ford Flex Members
  • 1 posts
  • Region:Canada Ontario
  • Location:Canada
  • Current Vehicle:Flex 2010

Posted 08 February 2017 - 08:56 AM

I had the same issue last summer, had to get the passenger side blender door actuator motor replaced.  About $400 at the dealer.  

 

Possibly could do it yourself, but I did not.



#7 OFFLINE   BrianD74

BrianD74

    New Flex Member

  • Ford Flex Members
  • 1 posts
  • Region:U.S. Southern Atlantic
  • Location:Villa Rica, GA
  • Current Vehicle:2014 Ford Flex Limited

Posted 05 August 2017 - 02:33 PM

Passenger side is the same, always on full cold, no matter the position (floor, vent, or defrost).  Just finished changing both the drivers and passengers side blend actuators with absolutely no change.  Please help!!!!



#8 OFFLINE   mmsstar

mmsstar

    New Flex Member

  • Ford Flex Members
  • 256 posts
  • Region:Decline
  • Location:Mike in Cleveland Area
  • Current Vehicle:2011 SE

Posted 05 August 2017 - 03:49 PM

On the dual zone system there are 4 BDAs, 2 on the drivers side and 2 on the passenger side. On the drivers side there is the Defrost/Panel/Floor Mode door actuator and the Drivers Temperature Blend Door Actuator. On the passenger side you have the Air Inlet Mode Door Actuator which should be the one there on the blower housing behind the glove box door and the Passenger Side Temperature Blend Door Actuator which is higher and more towards the center. You may have changed the  Air Inlet Mode Door Actuator.








Custom Search




Privacy Policy Terms of Service ·